输入n个朋友的信息,包括姓名、生日、电话号码,本题要求编写程序,按照年龄从大到小的顺序依次输出通讯录。题目保证所有人的生日均不相同。


输入格式:

输入第一行给出正整数n(<10)。随后n行,每行按照“姓名 生日 电话号码”的格式给出一位朋友的信息,其中“姓名”是长度不超过10的英文字母组成的字符串,“生日”是yyyymmdd格式的日期,“电话号码”是不超过17位的数字及+、-组成的字符串。


输出格式:

按照年龄从大到小输出朋友的信息,格式同输出。


输入样例:

3

zhang 19850403 13912345678

wang 19821020 +86-0571-88018448

qian 19840619 13609876543

输出样例:

wang 19821020 +86-0571-88018448

qian 19840619 13609876543

zhang 19850403 13912345678

#include <stdio.h>
#include <malloc.h>
#define SIZE 20

typedef struct Information
{
    char name[SIZE];
    long int birthday;
    char phone[SIZE];

} Information;

void func(Information *friend,int n);

int main(){
    int n;
    scanf("%d",&n);
    Information *friend=(Information*)calloc(n,sizeof(Information));
    for (int i = 0; i < n; i++)
    {
        scanf("%s %ld %s",&friend[i].name,&friend[i].birthday,&friend[i].phone);
    }

    func(friend,n);

}

void func(Information *friend,int n){

    Information temp;
    int index=0;

    //SelectSort
    for (int i = 0; i < n; i++)
    {
        index=i;
        for (int j = i; j < n; j++)
        {
            if (friend[j].birthday<friend[index].birthday)
            {
                index=j;
            }
        }

        temp=friend[i];
        friend[i]=friend[index];
        friend[index]=temp;
    }

    for (int i = 0; i < n; i++)
    {
        printf("%s %ld %s\n",friend[i].name,friend[i].birthday,friend[i].phone);
    }

}


点赞(0)
 

0.0分

0 人评分

C语言网提供由在职研发工程师或ACM蓝桥杯竞赛优秀选手录制的视频教程,并配有习题和答疑,点击了解:

一点编程也不会写的:零基础C语言学练课程

解决困扰你多年的C语言疑难杂症特性的C语言进阶课程

从零到写出一个爬虫的Python编程课程

只会语法写不出代码?手把手带你写100个编程真题的编程百练课程

信息学奥赛或C++选手的 必学C++课程

蓝桥杯ACM、信息学奥赛的必学课程:算法竞赛课入门课程

手把手讲解近五年真题的蓝桥杯辅导课程

评论列表 共有 0 条评论

暂无评论