私信TA

用户名:uq_98722666428

访问量:73

签 名:

等  级
排  名 28988
经  验 494
参赛次数 0
文章发表 1
年  龄 0
在职情况 学生
学  校
专  业

  自我简介:

TA的其他文章

输入n个朋友的信息,包括姓名、生日、电话号码,本题要求编写程序,按照年龄从大到小的顺序依次输出通讯录。题目保证所有人的生日均不相同。


输入格式:

输入第一行给出正整数n(<10)。随后n行,每行按照“姓名 生日 电话号码”的格式给出一位朋友的信息,其中“姓名”是长度不超过10的英文字母组成的字符串,“生日”是yyyymmdd格式的日期,“电话号码”是不超过17位的数字及+、-组成的字符串。


输出格式:

按照年龄从大到小输出朋友的信息,格式同输出。


输入样例:

3

zhang 19850403 13912345678

wang 19821020 +86-0571-88018448

qian 19840619 13609876543

输出样例:

wang 19821020 +86-0571-88018448

qian 19840619 13609876543

zhang 19850403 13912345678

#include <stdio.h>
#include <malloc.h>
#define SIZE 20

typedef struct Information
{
    char name[SIZE];
    long int birthday;
    char phone[SIZE];

} Information;

void func(Information *friend,int n);

int main(){
    int n;
    scanf("%d",&n);
    Information *friend=(Information*)calloc(n,sizeof(Information));
    for (int i = 0; i < n; i++)
    {
        scanf("%s %ld %s",&friend[i].name,&friend[i].birthday,&friend[i].phone);
    }

    func(friend,n);

}

void func(Information *friend,int n){

    Information temp;
    int index=0;

    //SelectSort
    for (int i = 0; i < n; i++)
    {
        index=i;
        for (int j = i; j < n; j++)
        {
            if (friend[j].birthday<friend[index].birthday)
            {
                index=j;
            }
        }

        temp=friend[i];
        friend[i]=friend[index];
        friend[index]=temp;
    }

    for (int i = 0; i < n; i++)
    {
        printf("%s %ld %s\n",friend[i].name,friend[i].birthday,friend[i].phone);
    }

}


 

0.0分

1 人评分

  评论区